This project has moved and is read-only. For the latest updates, please go here.

Error Message

Aug 8, 2010 at 5:31 AM

I'm using Windows 7 64-bit and Skype 5.0 beta. I can open this application, but when I click 'connect to skype' I get an error message: "can not receive COM-classfactory for component with CLSID {830690FC-BF2F-47A6-AC2D-330BCB402664} because of the following error: 80040154"


I have no idea what this means. Any help I'll be grateful for :)

Aug 13, 2010 at 4:38 PM

maybe the Skype4com object has changed with Skype 5. When it is properly released I'll maybe have a look into updating the references


Aug 14, 2010 at 3:45 AM

Thank you very much for replying.


I don't think that is the case because I have talked to others that use Skype 5 and I can hear their voices being changed with this program. I'll try a different version of Skype to see if that may be the problem.

Jun 11, 2011 at 3:38 AM

I'm getting the same error.

Windows 7 Ultimate x64, AMD Phenom II X4 940 CPU, Skype

Exact error text copied below.




Unhandled exception has occurred in your application.  If you click Continue, the application will ignore this error and attempt to continue.  If you click Quit, the application will close immediately.

Retrieving the COM class factory for component with CLSID {830690FC-BF2F-47A6-AC2D-330BCB402664} failed due to the following error 80040154


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {830690FC-BF2F-47A6-AC2D-330BCB402664} failed due to the following error: 80040154.
   at SkypeFx.MicInterceptor..ctor(ILog log, EffectChain effects)
   at SkypeFx.MainFormAudioGraph.ConnectToSkpe()
   at SkypeFx.MainForm.set_SkypeMode(Boolean value)
   at SkypeFx.MainForm.toolStripButtonSkype_Click(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripButton.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 2.0.50727.5444 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/AudioEffectTestApp/SkypeFx.exe
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/
    Assembly Version: 2008.11.24.0
    Win32 Version: 2008.11.24.0
    CodeBase: file:///C:/AudioEffectTestApp/System.ComponentModel.Composition.DLL
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Web.Services/
    Assembly Version:
    Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/AudioEffectTestApp/JSNet.DLL
    Assembly Version:
    Win32 Version: 3.5.30729.5420 built by: Win7SP1
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Core/
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/AudioEffectTestApp/NAudio.DLL
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/AudioEffectTestApp/Interop.SKYPE4COMLib.DLL

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

    < jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Dec 22, 2011 at 10:49 PM

I've updated now to use the latest Skype4Com, please try again with version 1.1


Dec 27, 2011 at 11:28 AM

Still not working. I just downloaded your newest version and updated to Skype

Dec 27, 2011 at 3:07 PM

hmmm, can you try running regsvr32 on Skype4Com.dll?

Press Start, type regsvr32 and then drag Skype4Com.dll into the textbox and it will put the full path in.


Dec 27, 2011 at 3:53 PM

I only have a file named Interop.SKYPE4COMLib.dll

If I try to register it I get this message:

"DllRegisterServer-EntryPoint not found" (translated)


I used this command:
regsvr32 Interop.SKYPE4COMLib.dll

Dec 27, 2011 at 5:12 PM

It's working now. I didn't know I had to download Skype4Com.dll myself. I did this and registered it. All is working fine now.

Dec 28, 2011 at 10:36 PM

OK, glad it's working for you. I'll try to create a proper installer that can register the skype4com DLL for the next version